pip:处理多个Python版本?

问题:

有没有办法让pip玩多个版本的Python?例如,我想使用pip显式安装到我的站点2.5安装或我的站点2.6安装。
例如,使用easy_install,我使用easy_install-2.{5,6}
而且,是的 – 我知道virtualenv,而不是 – 这不是解决这个特殊问题的办法。

回答:

自版本0.8以来,Pip支持pip-{version}。您可以使用它与easy_install-{version}相同

$ pip-2.5 install myfoopackage
$ pip-2.6 install otherpackage
$ pip-2.7 install mybarpackage

 编辑:在版本1.5中,pip将其模式更改为使用pipVERSION而不是pip-VERSION。如果您有pip >= 1.5,您应该使用以下内容

$ pip2.6 install otherpackage
$ pip2.7 install mybarpackage

查看https://github.com/pypa/pip/pull/1053了解详情
参考文献:

 
 
Code问答: http://codewenda.com/topics/python/
Stackoverflow: pip: dealing with multiple Python versions?

*转载请注明本文链接以及stackoverflow的英文链接

发表评论

电子邮件地址不会被公开。 必填项已用*标注

+ 67 = 69