Android需要编译器合规级别为5.0或6.0。找到’1.7’。请使用Android工具>修复项目属性

问题:

有没有人有类似的问题,我导入Android项目,我得到
错误像

[2011-10-03 17:20:09 - Screen] Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties.
[2011-10-03 17:21:55 - App] Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties.
[2011-10-03 17:21:59 - App] Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties.

我有错误删除所有@Override以上的功能。我有Windows 7 x64,jvm7 x64。有人有线索是什么问题(我完成Android工具 – >修复项目属性,但没有帮助)

回答:

这不是问题,杰克。 Android SDK不是x64,但使用x64 jvm(和x64 eclipse IDE)可以正常工作。
如helios所说,您必须将项目兼容性设置为Java 5.0或Java 6.0。
要做到这一点,2个选项:

  1. 右键单击您的项目,然后选择"Android Tools -> Fix
    Project Properties"
    (如果这不工作,请尝试第二个选项)
  2. 右键单击项目并选择"Properties -> Java
    Compiler"
    ,选中“启用项目特定设置”并选择
    1.5或1.6从“编译器符合性设置”选择框。

 
 
Code问答: http://codewenda.com/topics/python/
Stackoverflow: Android requires compiler compliance level 5.0 or 6.0. Found ‘1.7’ instead. Please use Android Tools > Fix Project Properties

*转载请注明本文链接以及stackoverflow的英文链接

发表评论

电子邮件地址不会被公开。 必填项已用*标注

1 + 2 =