在NPM安装过程中如何使用不同版本的python?

问题:

我有终端访问VPS运行centos 5.9和默认的python 2.4.3安装。我也通过这些命令安装了python 2.7.3:(我使用make altinstall而不是make install

wget http://www.python.org/ftp/python/2.7.3/Python-2.7.3.tgz
tar -xf Python-2.7.3.tgz
cd Python-2.7.3
./configure
make
make altinstall

那么我通过这些命令从源安装了node.js:

python2.7 ./configure
make
make install

问题是,当我使用npm install并尝试安装一个需要python> 2.4.3的node.js包时,我得到这个错误:

gyp ERR! configure error
gyp ERR! stack Error: Python executable "python" is v2.4.3, which is not supported by gyp.
gyp ERR! stack You can pass the --python switch to point to Python >= v2.5.0 &amp; < 3.0.0.
gyp ERR! stack     at failPythonVersion (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:125:14)
gyp ERR! stack     at /usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:114:9

我应该如何“pass the –python switch to point to Python >= v2.5.0”

回答:

您可以使用--python选项到npm,如下所示:

npm install --python=python2.7

或将其设置为始终使用:

npm config set python python2.7

Npm依次将该选项传递给node-gyp。
(注意:我是Github的一个问题,在文档中包含这个问题,因为有这么多的问题;-))

Code问答: http://codewenda.com/topics/python/
Stackoverflow: How to use a different version of python during NPM install?

*转载请注明本文链接以及stackoverflow的英文链接

发表评论

电子邮件地址不会被公开。 必填项已用*标注

+ 38 = 47